Back to overview
Resolved

EU-1 is down.

Jun 18, 2026 at 12:48pm UTC
Affected services
EU-1

Resolved
Jun 18, 2026 at 3:54pm UTC

This has been resolved.

Updated
Jun 18, 2026 at 3:31pm UTC

We have implemented a fix and are monitoring the results. Servers will be functional again shortly.

Created
Jun 18, 2026 at 12:48pm UTC

We are aware of the issues with our EU-1 Node. We are working to fix it and will keep you updated.