Back to overview
Downtime
EU-1 is down.
Apr 24, 2026 at 2:44pm UTC
Affected services
EU-1
Resolved
Apr 24, 2026 at 3:26pm UTC
This incident has been resolved.
Affected services
Updated
Apr 24, 2026 at 3:14pm UTC
A fix has been implemented and we are monitoring the results.
Affected services
Created
Apr 24, 2026 at 2:44pm UTC
We're investigating an issue where servers on our EU-1 Node are inaccessible.
Affected services