Back to overview
Maintenance

Game Panel Maintenance

Apr 25, 2026 at 11:20am UTC  –  Apr 25, 2026 at 11:38am UTC
Affected services
game.blockbyte.host

Resolved
Apr 25, 2026 at 11:38am UTC

This has been resolved.

Created
Apr 25, 2026 at 11:20am UTC

Game Panel will be down for 10-15 minutes for all users. This is so we can transfer it to a more powerful server. This will fix any and all lag users have experienced on the Game Panel.